0

in insert mode, when i press space, my neovim doesn't print out the space immediately. instead, it prints in the right corner <20> and seems to wait for a mapping to complete. Although my mapleader is space, i have no mappings using <leader> for insert mode.

(update below)

:verbose imap <space> prints out that some plugins define mappings. Disabling those temporarily results in the correct behavior when pressing .

My updated question is therefore: how can i prevent those insert-mode mapping of ?

That means, i want to know how i can forbid the use of (which is btw. my <Leader>) in every insert-mode mapping.


pic

$ nvim -v
NVIM v0.2.0-655-g0ef2b07d6
Build type: RelWithDebInfo
Compilation: /usr/bin/cc -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -Wconversion -O2 -g -DDISABLE_LOG -Wall -Wextra -pedantic -Wno-unused-parameter -Wstrict-prototypes -std=gnu99 -Wvla -fstack-protector-strong -fdiagnostics-color=auto -DINCLUDE_GENERATED_DECLARATIONS -DHAVE_CONFIG_H -D_GNU_SOURCE -I/tmp/yaourt-tmp-toogley/aur-neovim-git/src/neovim-git/build/config -I/tmp/yaourt-tmp-toogley/aur-neovim-git/src/neovim-git/src -I/usr/include -I/usr/include -I/usr/include -I/usr/include -I/usr/include -I/usr/include -I/usr/include -I/tmp/yaourt-tmp-toogley/aur-neovim-git/src/neovim-git/build/src/nvim/auto -I/tmp/yaourt-tmp-toogley/aur-neovim-git/src/neovim-git/build/include
Compiled by toogley@arch-laptop

Optional features included (+) or not (-): +acl   +iconv    +jemalloc +tui      
For differences from Vim, see :help vim-differences

   system vimrc file: "$VIM/sysinit.vim"
  fall-back for $VIM: "/usr/share/nvim"
  • 1
    Did you confirm this by running :verbose imap <space> ? – Tommy A Mar 4 '17 at 17:03
  • @TommyA thanks a lot for that hint, didn't know that. I've updated my question. – toogley Mar 5 '17 at 0:21
2

If the plugin has some <plug>mapping variation point that could be used to override the default one thar use <leader>, well there will be a solution.

Otherwise, it's done on a per plugin basis.

Unless listing all i-mappings starting with <space> thanks to getcompletions() (IIRC) in an after/ plugin executed after all other plugins, I don't see any generic solution -- note that this won't solve ftplugins issues.

PS: there exist many forks of a.vim that have disabled the mappings that cause the disturbances in your case. (I even have a fork, for other reasons)

0

Have you tried using :nnoremap or :nmap

causing the mapping to exist only in normal mode

Instead of just :map or :noremap

Which causes the mapping to exist in all modes (I think)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.