0

Everywhere the highlight shows bold, it has a color of light yellow on my white background. This is not bold. Its unreadable. Is there anywhere I can change this color? I can clear the highlight where it is set, but it may be easier to change its color entirely.

  • 1
    You might look into a different color scheme if you have a lot of problems with the one you're using. – Tumbler41 Mar 3 '17 at 17:52
  • 1
    At the moment, I am having problem with one color that is used in more than one place. That doesn't make we want to change the whole scheme, unless that is what is needed. – Robert Jacobs Mar 3 '17 at 17:57
3

I assume you are running Vim in a terminal.

Every terminal can interpret bold differently. For example on OS X there is a setting "Use bright colors for bold text". So you should check the preferences of your terminal.

  • This is a vim setting. What to do when showing bold. In this case it is showing yellow foreground. This is not the terminal setting. In vim if you issue the :highlight command, you will see term=value, cterm=value. One of these setting is bold and is configurable in vim. – Robert Jacobs Mar 3 '17 at 19:20
  • You can change all these settings with highlight commands: :help :highlight – Tumbler41 Mar 3 '17 at 19:41
  • @RobertJacobs yes, if it says cterm=bold then Vim will send the escape code for bold but your terminal emulator controls how it is displayed. – laktak Mar 3 '17 at 19:46
  • A bad setting terra term created this problem. Thanks. – Robert Jacobs Mar 3 '17 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.