2

I have an issue where in MacVim, I don't get any syntastic/eslint related functionality. When I run !which eslint in macvim, I get "eslint not found" - eslint is definitely installed.

eslint not found on macvim

If I run !which eslint on iTerm, I get the correct location of eslint (/Users/fpe/.nvm/versions/node/v4.4.5/bin/eslint).

It looks like MacVim is not aware of my $PATH. I didn't set anything specifically. I am also using zsh, if that makes a difference.

How do I fix this?

  • They are both different. – Filype Jan 25 '17 at 15:00
  • 1
    If you're using zsh as your login shell, and setting PATH in .zprofile, consider adding -l to 'shellcmdflags' so that it runs a login shell and sources .zprofile – muru Jan 25 '17 at 15:49
  • Hmm yes that didn't help @muru – Filype Jan 26 '17 at 4:51
  • 1
    great, I get which eslint working now with a hardcoded PATH :) – Filype Jan 26 '17 at 5:16
  • 1
    I usually set PATH in .zshenv for this reason - it affects every invocation of zsh. – muru Jan 26 '17 at 5:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.