5

enter image description here

Reason: I've swapped my semi-colon and colon commands so that entering the command-line takes one less key-stroke:

nnoremap ; :
nnoremap : ;
vnoremap ; :
vnoremap : ;
nnoremap q; q:

But in the command-line prompt, the colon character still shows up. I would like this character to be a semi-colon instead so my brain doesn't have to deal with cognitive dissonance.

  • You can't. Life's too short to worry about such things anyway. – Antony Jan 15 '17 at 16:08
5

There is no configuration option that does this; change the ':' into ';' you need to change the vim source code (which lives on github).

The relevant line (as of the most recent commit on github) is found here.

You need to change fgetline(':', cookie, into fgetline(';', cookie,. (Other characters that do not clash with existing characters used for the command line such as =, /, ? should work as well, but I am not familiar enough with the source code to be sure.)

(Personal interjection: In general, this procedure is fragile and expose your vim installation to bugs. I wouldn't recommend it.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.