7

I'm running ArchLinux using the xfce4 terminal with vim-latex. Using this setup, I tried to follow the instructions here to conceal latex commands with unicode. However, after much effort, I still cannot get any concealing.

I followed all the directions from above, namely put

set cole=2
let g:tex_conceal="adgm"

in my ~/.vimrc file.

However, there is no difference even when I try type :set cole=2 manually in vim.

At first, I thought it might be because xfce4-terminal is having trouble with utf-8, but I then tried to edit .tex files in rxvt-unicode which definitely supports utf-8. Still, there wasn't any change. I also checked that indeed my vim is compiled with the +conceal option.

Is there something that I'm doing wrong?

  • Very belatedly, this seems to work okay for me in Vim 8.1 for LaTeX content such as \( \Phi \). What version of Vim are you using? Is syntax highlighting switched on and the filetype set? Could you add a very small sample LaTeX file where it doesn't work for you? – Rich Feb 3 at 14:54
  • Thanks for getting back to me. I think I figured it out eventually, although I don't remember what I did four years ago :( – Alex Wang Feb 3 at 16:45
  • 1
    Sorry I didn't see it sooner. Glad you got it working, though! I'm going to vote to close this question, as I don't think there's enough details in it to figure out why you couldn't get it working originally. – Rich Feb 3 at 16:49