2

First, sorry for the cross-posting. I have posted it in https://tex.stackexchange.com/q/345060 as well.

I am trying to enable forward search in vim-latex. Since it is not working, I tried a vanilla .vimrc:

"Vundle Plugins" {{{
filetype off
set rtp+=~/.vim/bundle/Vundle.vim/
call vundle#begin()
Plugin 'gmarik/Vundle.vim'
Plugin 'vim-latex/vim-latex'          "  Latex IDE
call vundle#end()
filetype plugin indent on
" Vundle done
" "}}}

"language specific staffs:

"LaTeX: {{{
let g:tex_flavor = 'latex'
let g:Tex_DefaultTargetFormat = 'pdf'
let g:Tex_ViewRule_pdf = 'evince'
let g:syntastic_tex_checkers = ['lacheck']
"}}}

and a few line of latex:

\documentclass[a4paper]{article}
\synctex=1
\begin{document}
Lorem ipsum dolor sit amet, consetetur sadipscing elitr,  sed diam nonumy eirmod tempor invidunt ut 
labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores 
et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem 
ipsum dolor sit amet, consetetur sadipscing elitr,  sed diam nonumy eirmod tempor invidunt ut labore et 
dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. 
Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit 
amet, consetetur sadipscing elitr,  sed diam nonumy eirmod tempor invidunt ut labore et dolore magna 
aliquyam erat, sed diam voluptua. 

At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus
est Lorem ipsum dolor sit amet.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat, 
vel illum dolore eu feugiat nulla facilisis at vero eros et accumsan et iusto odio dignissim qui blandit praesent 
luptatum zzril delenit augue duis dolore te feugait nulla facilisi. Lorem ipsum dolor sit amet, 
consectetuer adipiscing elit, sed diam nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat.

Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis 
nisl ut aliquip ex ea commodo consequat. Duis autem vel eum iriure dolor in hendrerit in 
vulputate velit esse molestie consequat, vel illum dolore eu feugiat nulla facilisis at 
vero eros et accumsan et iusto odio dignissim qui blandit praesent luptatum zzril delenit
augue duis dolore te feugait nulla facilisi.
Nam liber tempor cum soluta nobis eleifend option congue nihil imperdiet doming id quod mazim 
placerat facer possim assum. Lorem ipsum dolor sit amet, consectetuer adipiscing elit, sed diam 
nonummy nibh euismod tincidunt ut laoreet dolore magna aliquam erat volutpat. 
Ut wisi enim ad minim veniam, quis nostrud exerci tation ullamcorper suscipit lobortis nisl 
ut aliquip ex ea commodo consequat.
Duis autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat, 
vel illum dolore eu feugiat nulla facilisis.
hell
\end{document}

Obviously, it compiles fine, but, when I put cursor on a line, and do \ls, it prompts an evince window with error:

This file does not exists: /tmp/<line number where my cursor is>

I have also tried: https://tex.stackexchange.com/questions/2941/how-to-setup-synctex-with-vim-pdflatex-and-an-open-source-pdf-viewer-under-linu

but with now change.

  • Which shell are you using? This is sometimes a problem if you're using a non-Bourne shell such as fish or tcsh. – Martin Tournoij Dec 21 '16 at 15:35
  • I am using bash – BaRud Dec 21 '16 at 15:36
  • I am afraid, that depends on the definition of the \ls command. Have you tried contacting the maintainers of vim-latex suite? – Christian Brabandt Dec 21 '16 at 20:51
  • Hi, The link at the end of the OP shows its use with evince, and please also see vim-latex.sourceforge.net/documentation/latex-suite/…. Since its a vanila vimrc, I think \ls is what it is defined. For completeness, i have treids with dvi and xdvi, with no forward/reverse search – BaRud Dec 21 '16 at 21:23
  • that does not tell us, what exactly \ls is mapped to. – Christian Brabandt Dec 22 '16 at 8:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.