5

This might be a newbie question but I can't seem to find an answer anywhere.

I've created a custom colorscheme, but I don't know how to stop the character behind the cursor from becoming bold.

This is the Cursor line from my theme file.

Vim theme

It might be hard to see on the image but the g after the cursor is bold, or just darker.

Usually gui=NONE removes any effects from other elements. But this doesn't seem to work with the cursor.

  • This must be something related to gui vim only. Might even be a bug. Or just a feature to make sure the character behind the cursor is not hard to see. So, basically, if you're concerned about your colorscheme, you've nothing else to do. Maybe you could check if it also happens with other colorschemes. Most probably it does. But if it doesn't, you can then easily backtrack and pinpoint the problem. – klaus Apr 15 at 6:16
1

I can't tell what machine your using, but on my iMac I had the exact same issue and I've finally fixed it. The solution was to go to preferences and uncheck "Use Core Text renderer".

I no longer have the issue and as far as I can tell, there hasn't been any adverse affects from doing this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.