1

In Vim 7.4, I used to effectively deploy the visincr.vim plugin for such a task. However, I have recently moved to neovim and this won't work anymore.

The errors produced by :so % fills up the whole screen. Every line in the vimball raises the standard error: Not an editor command., followed by insanely long lines of cryptic characters and control sequences such as <e4><ab>͔<f8><94><99>.

Can anyone advise on the compatibility of this vimball plugin and neovim ?

Update:

I have unzipped the file and tried again. Now, it gives the following error:

E492: Not an editor command : UseVimball

Update 2: This has now been solved. I had to run :packadd vimball before attempting :so %. The vimball also had to be moved to one of the $VIMRUNTIME directories. Thanks to all who helped :)

  • as far as i know, vimballs should still be usable with neovim. – Christian Brabandt Dec 6 '16 at 14:57
  • Thank you for your answer. However, when I open the visincr.vba.gz file and type :so % , my screen gets filled with errors like the following. line 1: E492: Not an editor command: ^_<8b>^H^HU<dc><d5> – Krishna Dec 6 '16 at 14:58
  • Do you have a link to this file? Also, you can edit the question to include extra information such as errors (that doesn't work very well in comments due to limited formatting). – Martin Tournoij Dec 6 '16 at 15:01
  • That is useful information you should have mentioned in your question! Try unzipping the file manually before sourcing it. Perhaps the gzip autocommand is not run correctly for your neovim installation. – Christian Brabandt Dec 6 '16 at 15:03
  • 1
    You need to use :packadd vimball first, since this plugin is no longer loaded automatically (it's in /usr/share/nvim/runtime/pack/dist/opt/vimball on my system). – Martin Tournoij Dec 6 '16 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.