0

Question on vim latex suite (the link is provided to avoid confusion). When I see the compiled pdf using \lv command, it sometimes show error message spitted out by the viewer on top of the editing screen (shown on the picture).
Is there any way to suppress this error message perhaps by adding some simple line to .vimrc?

ubuntu 16.04
vim latex suite

The picture of error being superposed to the editing screen

2

This is a shell command run with :silent! !okular [..] in the Tex_ForwardSearchLaTeX() function (ftplugin/latex-suite/compiler.vim).

It looks like okular is printing some text to stdout or stderr – the silent! command only silences Vim :echo and :echoerr messages, not stdout from external programs.

To fix this you'll need to add something like >/dev/null 2>&1 to the end of the shell command. As far as I can see this plugin provides no such facility, but you could modify the source yourself. For example change:

execute execString

to something like:

execute execString . '>/ dev/null 2>&1'

You can also consider writing to the maintainer (listed at the top of :help latex-suite.txt) of the plugin to implement this as an option.

  • Thank you, I sent an e-mail with link to this post to the developer team. i voted up, but not accept this as an answer since it didn't solve the problem. – Tom Dec 7 '16 at 9:23
  • 1
    Add let g:Tex_ViewRule_pdf = 'okular >/dev/null 2>&1 on .vimrc – Tom Mar 2 '17 at 6:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.