1

I have set my .vimrc to open NERDTree on startup and whenever I open vim at the default location (~) I get this warning prompt:

NERDTree: Please wait, caching a large dir ... DONE (134 nodes cached).
Press ENTER or type command to continue

I can immediately skip the message with ENTER.

Does anyone know if I can set the trigger for the warning to something larger than "134 nodes". Or how else I could suppress this annoying prompt?

5
  • This is definitely not the answer you're looking for and I understand that but maybe you could consider stop using NERDTree and choose to use the built-in features (:find, :e, :grep) or choose a way to navigate your files which doesn't involve a project drawer. Vimcast has a really interesting article which explains why it would be a good idea to stop using nerdtree (it even show how to make the transition from NERDTree to something else).
    – statox
    Nov 22 '16 at 16:55
  • Now about your particular problem I don't know how to solve it but maybe it would be worth asking directly to the plugin author via the project issue tracker which seems to be pretty active. (Note that the number of opened issues in the tracker would be another argument to stop using nerdtree IMO ;-) )
    – statox
    Nov 22 '16 at 16:56
  • @statox Thanks for the tips! The approach described in the article makes sense and looks nice. But I'm a 'distraction-free' type. I never have multiple files visible at the same time (except for diff). I don't have the problem which the article is about to fix. I need the 'project drawer' for two reasons: 1) It centers the workspace and 2) I want a short overview of where the current file lives. stackoverflow.com/a/40732234/1612318
    – Rotareti
    Nov 22 '16 at 18:21
  • One could argue that using find and e is even more distraction free than nerdtree but 1) that's not the point of the question 2) whatever floats your boat is the correct solution :-) I hope someone here will be able to help you with your problem but I still think that you'll have more answers on the issue tracker.
    – statox
    Nov 22 '16 at 18:25
  • 1
    "but I still think that you'll have more answers on the issue tracker." That's plan b) ;-)
    – Rotareti
    Nov 22 '16 at 18:30
1

It seems like the (undocumented) variable g:NERDTreeNotificationThreshold might be what you are looking for (I have not tested this myself, but it is used in the plugin code for exactly your situation and nowhere else).

Thus setting it to a value higher than 134, e.g. let g:NERDTreeNotificationThreshold = 500 in your .vimrc should hopefully solve your problem.

1
  • Works like a charm!
    – Rotareti
    Dec 1 '16 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.