0

I have a strange issue with TypeScript or .ts files in terminal vim. I tried opening it from NERDTree or Control+P.

It finds the file but for some strange reason after I hit the Enter key from Control P it doesn't open, I tried hitting Enter multiple times it only adds lines to the status line at the bottom.

However if I press Ctrl + C it terminates and brings up the .ts content. It only happened recently but I don't know what I've done to cause this. It used to open fine, even though it took more than a second or two.

I am using:

OS: Mac OSX Sierra

Vim in the terminal

I have the following plugins:

  • vim-typescript
  • tsuquyomi

All I remember doing recently was npm install -g typescript tsc.

  • Its only happened recently but I don't know what I've done to cause this That how you'll know: how do i debug my vimrc – statox Nov 22 '16 at 13:42
  • @statox I'll give it a crack and see thanks. – TheLazyChap Nov 22 '16 at 14:18
1

So following fronm @statox suggestion to a previous debug thread.

I used the following command to trace my issue:

  1. Ensure it wasn't something in my .vimrc. FAILED - so it was my something in my .vimrc

  2. Use the following command to trace the .vimrc file

Command: vim --noplugin -D

  1. It detected error with the Tsuquyomi plugin.

  2. I don't know how I fixed bit but I re-downloaded the plugin and added the appropriate ts checker.

It seems to have fixed my current issue.

I suspect it was me doing the npm install -g typescript and tsc recently which would have overwritten something or add new binary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.