1

The following screenshot displays the sorcerer colorscheme displayed in mintty on cygwin windows with the following minttyrc:

enter image description here

# CursorColour=191,191,191
# ForegroundColour=220,220,204
# BackgroundColour=63,63,63
Black=63,63,63
Red=112,80,80
Green=96,180,138
Yellow=223,175,143
Blue=80,96,112
Magenta=220,140,195
Cyan=140,208,211
White=220,220,204
BoldBlack=112,144,128
BoldRed=220,163,163
BoldGreen=195,191,159
BoldYellow=240,223,175
BoldBlue=148,191,243
BoldMagenta=236,147,211
BoldCyan=147,224,227
BoldWhite=255,255,255
BoldAsFont=-1
Locale=en_US
Charset=UTF-8
FontHeight=14

This looks good and correct.

If I uncomment the first lines this and other colorschemes look bad: enter image description here

CursorColour=191,191,191
ForegroundColour=220,220,204
BackgroundColour=63,63,63
Black=63,63,63
Red=112,80,80
Green=96,180,138
Yellow=223,175,143
Blue=80,96,112
Magenta=220,140,195
Cyan=140,208,211
White=220,220,204
BoldBlack=112,144,128
BoldRed=220,163,163
BoldGreen=195,191,159
BoldYellow=240,223,175
BoldBlue=148,191,243
BoldMagenta=236,147,211
BoldCyan=147,224,227
BoldWhite=255,255,255
BoldAsFont=-1
Locale=en_US
Charset=UTF-8
FontHeight=14

The same thing happens with the same vimrc on my ubuntu using terminator. If I unset its color options then some colorschemes improve.

Both machines share the same vimrc:

In vim:

set t_Co?
t_Co=256

In terminal:

~ » echo $TERM
xterm-256color

Is there a way to either disable their colors when vim is running or to use another workaround?

  • I can't reproduce this in mintty (although I'm not using Cygwin). If you edit the line near the top of sorcerer.vim from let colors_name = "sorcerer" to let g:colors_name = "sorcerer", does that make any difference? – Rich Aug 15 '17 at 12:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.