1

I want to use the Solarized Light theme in both my Terminal and VIM.

I seem to have got it working in Terminal, I downloaded the entire package from their website, tree output, and then in my terminal preferences I imported the Solarized Light xterm-256color profile from the download.

enter image description here

And I set this as my default profile and it seems to look ok:

enter image description here

Then, I proceeded to try to set VIM's color scheme to Solarized Light as well, so I git-cloned git://github.com/altercation/vim-colors-solarized.git into my ~/.vim/bundle (I use Pathogen).

See a paste bin of some ls and tree outputs in my ~/.vim/bundle here

But even after adding the correct information to my vimrc it looks really ugly:

enter image description here

Why does it not seem to work? You can see around the edges of the terminal the colors it should be, why is the text so unreadable and the background color so ugly?

  • try :set colorscheme and tab to see if solarized option is there. – Ashok Nov 5 '16 at 14:21
  • What's the value of t_Co and what's in $TERM? Have you tried setting g:solarized_termcolors to 256 (before calling colorscheme solarized)? – grodzik Nov 5 '16 at 14:32
  • @Ashok set colorscheme tells me: E518: Unknown option: colorscheme, however colorscheme ^D tells me that solarized is an option. – theonlygusti Nov 5 '16 at 14:57
  • @grodzik t_Co is 256, $TERM is xterm-256color, and I have not tried setting g:solarized_termcolors before setting colorscheme, however setting it afterwards seems to change nothing. – theonlygusti Nov 5 '16 at 14:59
  • @theonlygusti sorry its :colorscheme – Ashok Nov 5 '16 at 15:07
1

I fixed the issue by setting g:solarized_termcolors to 16 instead of 256.

let g:solarized_termcolors=16
0

According to this link, you should set g:solarized_termcolors to 256, but you need to do that before calling colorscheme solarized

let g:solarized_termcolors=256
colorscheme solarized
  • This uses colors different to the one in the screenshots on the main site. – theonlygusti Nov 5 '16 at 15:20
  • See here - on the right is my terminal – theonlygusti Nov 5 '16 at 15:22
  • So I can't help much more here then, I'm not a Mac user. One only thing that I could suggest is to check g:solarized_termtrans. On solarized page in Option details section there is a note about Mac Terminal.app, maybe that will help you. That one eventually needs to be set before calling colorscheme solarized as well. – grodzik Nov 5 '16 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.