0

I have installed python 3.5 from the official source, and everything was working. I decided to try vim as a sort of command line IDE. Most plugins worked with vim, but when I tried YouCompleteMe for text completion, vim had this import error in messages:

Traceback (most recent call last):
  File "<string>", line 22, in <module>
  File "/home/jack/.vim/bundle/YouCompleteMe/autoload/../python/ycm/base.py", line 27, in <module>
    from ycm import vimsupport
  File "/home/jack/.vim/bundle/YouCompleteMe/autoload/../python/ycm/vimsupport.py", line 33, in <module>
    from ycmd.utils import ( GetCurrentDirectory, JoinLinesAsUnicode, ToBytes,
  File "/home/jack/.vim/bundle/YouCompleteMe/python/ycm/../../third_party/ycmd/ycmd/utils.py", line 30, in <module>
    import socket
  File "/usr/local/lib/python3.5/socket.py", line 49, in <module>
    import _socket
ImportError: /usr/local/lib/python3.5/lib-dynload/_socket.cpython-35m-arm-linux-gnueabihf.so: undefined symbol: PyByteArray_Type

This thread tells me that it isn't a problem with vim or YouCompleteMe, but a problem with the compatability between vim and my compilation of python 3.5. What are the differences between the package for python 3.3 that is in apt-get and the python 3.5 straight from python's website? What are the additions that are made in the package that make it more compatible with vim? Is there a special way to make python 3.5 compatible with vim and other linux features that I have not found yet?

Basically, what would I have to do to make python 3.5 compatible with vim?

I'm on a raspberry pi running raspbian jessie.

migrated from unix.stackexchange.com Nov 4 '16 at 17:22

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems.

1

I don't have experience with Rasberry Pi but how about try to install python 3.5 using apt-get? I found that it's available in repository: http://archive.raspbian.org/raspbian/pool/main/p/python3.5/

  • Hmm I didn't think that there wasn't a package for python 3.5. I'll check with apt-cache. – jath03 Nov 4 '16 at 2:01
  • Nothing came up when I used sudo apt-cache search python3.5 maybe update your answer to include how to add the repository in the link. From the output of sudo apt-get update it looks like it just gets updates from the jessie archive. – jath03 Nov 4 '16 at 2:23
  • Ok, after researching why python3.5 wasn't in apt, I found this which explains why it wasn't in apt-get. – jath03 Nov 4 '16 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.