1

I am using Ubuntu 16.04. I installed Neovim using apt-get. I downloaded the plug.vim script & put it into the autoload folder in ~/.config/nvim. I put the following in my init.vim:

call plug#begin()
Plug 'https://github.com/luochen1990/rainbow.git'
Plug 'https://github.com/davisdude/vim-love-docs.git'
Plug 'https://github.com/morhetz/gruvbox.git'
call plug#end()

I did :PlugInstall. The plugins were installed & show OK in :PlugStatus. But they are not working. As in nothing's changed at all.

I am new to both Vim & Neovim. I tried googling for a solution but there is almost no information on Neovim.

3

My guess is that you haven't activated the plug-ins. In the rainbow case you should add

let g:rainbow_active = 1

to your init file (Neovim's one is located in ~/.config/nvim/init.vim). In case of gruvbox you should add

colorscheme gruvbox 

Usually it's done after the plug#end().

As for vim-love-docs, the GitHub code only includes the code for generating the plugin. From the GitHub page:

Vundle: Clone the repo and follow the instructions below to generate the documentation (or download from vim.org). Then activate it using Plugin 'file:///home/gmarik/path/to/plugin'. See :h vundle for more.

  • Thanks! That did the trick. I am new to vim. Do I activate every plugin like rainbow or does every plugin have different methods of activation? If so, where is it displayed? – NightMare Nov 1 '16 at 17:17
  • 1
    All color schemes are activated the same way: colorscheme name. Other plug-ins have it's own method, and it's usually explained in the README or the docs. To consult the docs run :help plug-in-name (you can use Tab for autocompletion) after installation. Usually plug-ins that need to be enable expose a global variable that sets that status like: let g:pluginname_enabled=1 (VimL doesn't have boolean primitives so 1 means true). Other plug-ins are activated by default so if you want to disabled them at start up you must do the oposite (set the variable to 0). – Tae Nov 1 '16 at 17:35
  • Thank you very much Tae. I really appreciate your help. You just got vim/neovim another user! ;) – NightMare Nov 1 '16 at 17:48
  • I'm glad I could helped you :) Welcome aboard! And don't hesitate to ask questions: Vim has a steep learning curve. I have been using Vim for 5 years (and at least a year ago I switched to Neovim) and I'm always learning something new. – Tae Nov 1 '16 at 20:24
0

From the NeoVim FAQ:

Can I use Lua-based Vim plugins (e.g. neocomplete)?

Not yet. The legacy Vim if_lua interface is not (yet) supported.

vim-love-docs is Lua-based, so that is likely why that plugin does not appear to be working. If something is failing in the loading of that plugin, it may affect the loading of subsequent plugins (don't quote me on that though; I'm not intimately familiary with the inner workings of the plugin system).

Additionally, there are various parts of vim that are changed, not yet implemented or removed. I did not examine the source of the plugins you are using, but if they utilize any of the features you may see undefined behavior as a result.

I would recommend uninstalling all of the plugins then reinstalling the two that are not Lua-based one at a time.

  • I removed the love-docs plugin from my init.vim and ran PlugClean. But again nothing happens:( – NightMare Nov 1 '16 at 14:43
  • @NightMare As a note, the plugin is written in Lua, but only uses Lua to generate the plugin scripts, which are vimscript. See my edit to the accepted answer for how to use vim-love-docs with Vundle. – DavisDude Jul 22 '17 at 4:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.