1

I'm a longtime user of vim on Archlinux. I've been away from this system for a few months, so I can't be sure when this started (but I've made updates during this time, too).

Every time I open the app, I get an error about the spelling file.

$ vim
Warning: Cannot find word list "en.utf-8.spl" or "en.ascii.spl"
Warning: Cannot find word list "en.utf-8.spl" or "en.ascii.spl"
Warning: Cannot find word list "en.utf-8.spl" or "en.ascii.spl"
Press ENTER or type command to continue

$ vim --version
VIM - Vi IMproved 8.0 (2016 Sep 12, compiled Sep 15 2016 10:11:05)
Included patches: 1-5
Compiled by Arch Linux

$ sudo pacman -Ss vim | grep installed
extra/vim 8.0.0005-1 [installed]
extra/vim-runtime 8.0.0005-1 [installed]
community/ranger 1.7.2-1 [installed]

I reinstalled the app, but the problem persists. The problem is for all users.

  • 2
    This doesn't come from the package. It seems that you have set spell enabled but didn't downloaded the spell files. You can have a look at this blog post and this question. I think the solution is to download the spell files and put them in ~/.vim/spell. Note that usually vim offers to download the files automatically so I think the question I linked before might help you. – statox Oct 25 '16 at 8:57
1

I struggled with the same problem and my vimrc was containing this lines. It disables the default, built-in netrw plugin. I don't know why but somehow spell files couldn't be downloaded if netrw disabled.

let g:loaded_netrwPlugin = 1 " Disables netrw.

Solution was at least for me to delete this line to enable netrw again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.