2

Dears,

I have my .vimrc as

set nocompatible 
filetype off

syntax on
set nu

" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()

" let Vundle manage Vundle, required
Plugin 'gmarik/Vundle.vim'
Plugin 'vim-airline/vim-airline'
Plugin 'vim-airline/vim-airline-themes'

" All of your Plugins must be added before the following line
call vundle#end()            " required
filetype plugin indent on    " required

I want to set AirlineTheme e.g.

:AirlineTheme molokai

Unfortunately the theme is not applied and vim editor stays visually the same with no change. I use ubuntu 14.04. I wonder what's wrong ? Somehow GNOME terminal should be set prior the vim is used?

Thank you.

Note: VIM

r59400@Latitude:~$ vim --version
VIM - Vi IMproved 7.4 (2013 Aug 10, compiled Jan  2 2014 19:39:32)
Included patches: 1-52
Modified by pkg-vim-maintainers@lists.alioth.debian.org
Compiled by buildd@
Huge version without GUI.  Features included (+) or not (-):
+acl             +farsi           +mouse_netterm   +syntax
+arabic          +file_in_path    +mouse_sgr       +tag_binary
+autocmd         +find_in_path    -mouse_sysmouse  +tag_old_static
-balloon_eval    +float           +mouse_urxvt     -tag_any_white
-browse          +folding         +mouse_xterm     -tcl
++builtin_terms  -footer          +multi_byte      +terminfo
+byte_offset     +fork()          +multi_lang      +termresponse
+cindent         +gettext         -mzscheme        +textobjects
-clientserver    -hangul_input    +netbeans_intg   +title
-clipboard       +iconv           +path_extra      -toolbar
+cmdline_compl   +insert_expand   -perl            +user_commands
+cmdline_hist    +jumplist        +persistent_undo +vertsplit
+cmdline_info    +keymap          +postscript      +virtualedit
+comments        +langmap         +printer         +visual
+conceal         +libcall         +profile         +visualextra
+cryptv          +linebreak       +python          +viminfo
+cscope          +lispindent      -python3         +vreplace
+cursorbind      +listcmds        +quickfix        +wildignore
+cursorshape     +localmap        +reltime         +wildmenu
+dialog_con      -lua             +rightleft       +windows
+diff            +menu            -ruby            +writebackup
+digraphs        +mksession       +scrollbind      -X11
-dnd             +modify_fname    +signs           -xfontset
-ebcdic          +mouse           +smartindent     -xim
+emacs_tags      -mouseshape      -sniff           -xsmp
+eval            +mouse_dec       +startuptime     -xterm_clipboard
+ex_extra        +mouse_gpm       +statusline      -xterm_save
+extra_search    -mouse_jsbterm   -sun_workshop    -xpm

Terminal

GNOME Terminal 3.6.2
A terminal emulator for the GNOME desktop
  • The command AirlineTheme is not available after the vimrc file has been load. You need to put it into an VimEnter autocommand or set the theme manually, like this :let g:airline_theme='dark'. BTW: This is all in the documentation. You should read it. – Christian Brabandt Oct 24 '16 at 5:46
1

I want to set AirlineTheme e.g.

:ArlineTheme molokai

Seems you made a mistake, shouldn't it be :AirlineTheme molokai

Also try setting it in vimrc and see if the problem persists. To set it in your .vimrc, use:

let g:airline_theme='<theme>'

e.g.

let g:airline_theme='simple'
  • you're right it's typo; it should be :AirlineTheme molokai; anyway I did set as you suggested and problem persists... – user3428154 Oct 23 '16 at 20:21
  • give set t_Co=256 (in .vimrc) a try :D – Ashok Oct 23 '16 at 20:29
  • with that set no change – user3428154 Oct 23 '16 at 20:32
  • does any other theme work ? – Ashok Oct 23 '16 at 20:44
  • nope, other themes are not working... – user3428154 Oct 23 '16 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.