deleted 10 characters in body; edited tags; edited title
Source Link
D. Ben Knoble
  • 19.1k
  • 3
  • 21
  • 48

ftplugin not working in MS Windowsloading

This is my .vimrc

set nocompatible              " be iMproved, required
filetype off                  " required
" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')
" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'
Plugin 'altercation/vim-colors-solarized'
Plugin 'ycm-core/YouCompleteMe'
Plugin 'vim-latex/vim-latex'
Plugin 'vim-scripts/LanguageTool'
Plugin 'vim-airline/vim-airline'
Plugin 'scrooloose/nerdtree'
Plugin 'tpope/vim-fugitive'
Plugin 'vimoutliner/vimoutliner'
Plugin 'majutsushi/tagbar'
call vundle#end()            " required
filetype plugin indent on    " required

set encoding=utf-8
let g:languagetool_jar='$HOME/Downloads/LanguageTool-4.7/languagetool-commandline.jar'

" color scheme
set background=light
let g:solarized_termcolors=256
colorscheme solarized
syntax enable

" tab behaviour
set expandtab
set tabstop=4
"set shiftwidth=4

" UI
set number
set showcmd
set cursorline
filetype plugin indent on

set wildmenu
set lazyredraw
set showmatch
set guifont=Consolas:h12:cANSI:qDRAFT

" searching
set hlsearch
nnoremap <leader><space> :nohlsearch<CR>

" general behaviour
let mapleader=","
set backspace=2
set autoread
set foldmethod=syntax

let g:tex_flavor='latex'
let g:Tex_DefaultTargetFormat='pdf'
let g:Tex_MultipleCompileFormats='pdf'

I have the following files under C:\Users\Jordi\.vim\after\ftplugin with different indent settings and other settings

/Users/Jordi/.vim/
~ after/ftplugin/
    matlab.vim
    tex.vim
    arduino.vim
+ bundle/

The output of :filetype yields everything ON

When I check :scriptnames the ftplugin scripts are never being loaded.

What am I doing wrong? Thanks

ftplugin not working in MS Windows

This is my .vimrc

set nocompatible              " be iMproved, required
filetype off                  " required
" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')
" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'
Plugin 'altercation/vim-colors-solarized'
Plugin 'ycm-core/YouCompleteMe'
Plugin 'vim-latex/vim-latex'
Plugin 'vim-scripts/LanguageTool'
Plugin 'vim-airline/vim-airline'
Plugin 'scrooloose/nerdtree'
Plugin 'tpope/vim-fugitive'
Plugin 'vimoutliner/vimoutliner'
Plugin 'majutsushi/tagbar'
call vundle#end()            " required
filetype plugin indent on    " required

set encoding=utf-8
let g:languagetool_jar='$HOME/Downloads/LanguageTool-4.7/languagetool-commandline.jar'

" color scheme
set background=light
let g:solarized_termcolors=256
colorscheme solarized
syntax enable

" tab behaviour
set expandtab
set tabstop=4
"set shiftwidth=4

" UI
set number
set showcmd
set cursorline
filetype plugin indent on

set wildmenu
set lazyredraw
set showmatch
set guifont=Consolas:h12:cANSI:qDRAFT

" searching
set hlsearch
nnoremap <leader><space> :nohlsearch<CR>

" general behaviour
let mapleader=","
set backspace=2
set autoread
set foldmethod=syntax

let g:tex_flavor='latex'
let g:Tex_DefaultTargetFormat='pdf'
let g:Tex_MultipleCompileFormats='pdf'

I have the following files under C:\Users\Jordi\.vim\after\ftplugin with different indent settings and other settings

/Users/Jordi/.vim/
~ after/ftplugin/
    matlab.vim
    tex.vim
    arduino.vim
+ bundle/

The output of :filetype yields everything ON

When I check :scriptnames the ftplugin scripts are never being loaded.

What am I doing wrong? Thanks

ftplugin not loading

This is my .vimrc

set nocompatible              " be iMproved, required
filetype off                  " required
" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')
" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'
Plugin 'altercation/vim-colors-solarized'
Plugin 'ycm-core/YouCompleteMe'
Plugin 'vim-latex/vim-latex'
Plugin 'vim-scripts/LanguageTool'
Plugin 'vim-airline/vim-airline'
Plugin 'scrooloose/nerdtree'
Plugin 'tpope/vim-fugitive'
Plugin 'vimoutliner/vimoutliner'
Plugin 'majutsushi/tagbar'
call vundle#end()            " required
filetype plugin indent on    " required

set encoding=utf-8
let g:languagetool_jar='$HOME/Downloads/LanguageTool-4.7/languagetool-commandline.jar'

" color scheme
set background=light
let g:solarized_termcolors=256
colorscheme solarized
syntax enable

" tab behaviour
set expandtab
set tabstop=4
"set shiftwidth=4

" UI
set number
set showcmd
set cursorline
filetype plugin indent on

set wildmenu
set lazyredraw
set showmatch
set guifont=Consolas:h12:cANSI:qDRAFT

" searching
set hlsearch
nnoremap <leader><space> :nohlsearch<CR>

" general behaviour
let mapleader=","
set backspace=2
set autoread
set foldmethod=syntax

let g:tex_flavor='latex'
let g:Tex_DefaultTargetFormat='pdf'
let g:Tex_MultipleCompileFormats='pdf'

I have the following files under C:\Users\Jordi\.vim\after\ftplugin with different indent settings and other settings

/Users/Jordi/.vim/
~ after/ftplugin/
    matlab.vim
    tex.vim
    arduino.vim
+ bundle/

The output of :filetype yields everything ON

When I check :scriptnames the ftplugin scripts are never being loaded.

What am I doing wrong?

deleted 5 characters in body; edited title
Source Link

ftplugin not working in windowsMS Windows

This is my .vimrc

set nocompatible              " be iMproved, required
filetype off                  " required
" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')
" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'
Plugin 'altercation/vim-colors-solarized'
Plugin 'ycm-core/YouCompleteMe'
Plugin 'vim-latex/vim-latex'
Plugin 'vim-scripts/LanguageTool'
Plugin 'vim-airline/vim-airline'
Plugin 'scrooloose/nerdtree'
Plugin 'tpope/vim-fugitive'
Plugin 'vimoutliner/vimoutliner'
Plugin 'majutsushi/tagbar'
call vundle#end()            " required
filetype plugin indent on    " required

set encoding=utf-8
let g:languagetool_jar='$HOME/Downloads/LanguageTool-4.7/languagetool-commandline.jar'

" color scheme
set background=light
let g:solarized_termcolors=256
colorscheme solarized
syntax enable

" tab behaviour
set expandtab
set tabstop=4
"set shiftwidth=4

" UI
set number
set showcmd
set cursorline
filetype plugin indent on

set wildmenu
set lazyredraw
set showmatch
set guifont=Consolas:h12:cANSI:qDRAFT

" searching
set hlsearch
nnoremap <leader><space> :nohlsearch<CR>

" general behaviour
let mapleader=","
set backspace=2
set autoread
set foldmethod=syntax

let g:tex_flavor='latex'
let g:Tex_DefaultTargetFormat='pdf'
let g:Tex_MultipleCompileFormats='pdf'

I have the following files under C:\Users\Jordi\.vim\after\ftplugin with different indent settings and other settings

/Users/Jordi/.vim/
~ after/ftplugin/
    matlab.vim
    tex.vim
    arduino.vim
+ bundle/

The output of :filetype yields everything ON

When I check :scriptnames the ftplugin scripts are never being loaded.

What am I doing wrong? Thanks

ftplugin not working in windows

This is my .vimrc

set nocompatible              " be iMproved, required
filetype off                  " required
" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')
" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'
Plugin 'altercation/vim-colors-solarized'
Plugin 'ycm-core/YouCompleteMe'
Plugin 'vim-latex/vim-latex'
Plugin 'vim-scripts/LanguageTool'
Plugin 'vim-airline/vim-airline'
Plugin 'scrooloose/nerdtree'
Plugin 'tpope/vim-fugitive'
Plugin 'vimoutliner/vimoutliner'
Plugin 'majutsushi/tagbar'
call vundle#end()            " required
filetype plugin indent on    " required

set encoding=utf-8
let g:languagetool_jar='$HOME/Downloads/LanguageTool-4.7/languagetool-commandline.jar'

" color scheme
set background=light
let g:solarized_termcolors=256
colorscheme solarized
syntax enable

" tab behaviour
set expandtab
set tabstop=4
"set shiftwidth=4

" UI
set number
set showcmd
set cursorline
filetype plugin indent on

set wildmenu
set lazyredraw
set showmatch
set guifont=Consolas:h12:cANSI:qDRAFT

" searching
set hlsearch
nnoremap <leader><space> :nohlsearch<CR>

" general behaviour
let mapleader=","
set backspace=2
set autoread
set foldmethod=syntax

let g:tex_flavor='latex'
let g:Tex_DefaultTargetFormat='pdf'
let g:Tex_MultipleCompileFormats='pdf'

I have the following files under C:\Users\Jordi\.vim\after\ftplugin with different indent settings and other settings

/Users/Jordi/.vim/
~ after/ftplugin/
    matlab.vim
    tex.vim
    arduino.vim
+ bundle/

The output of :filetype yields everything ON

When I check :scriptnames the ftplugin scripts are never being loaded.

What am I doing wrong? Thanks

ftplugin not working in MS Windows

This is my .vimrc

set nocompatible              " be iMproved, required
filetype off                  " required
" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')
" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'
Plugin 'altercation/vim-colors-solarized'
Plugin 'ycm-core/YouCompleteMe'
Plugin 'vim-latex/vim-latex'
Plugin 'vim-scripts/LanguageTool'
Plugin 'vim-airline/vim-airline'
Plugin 'scrooloose/nerdtree'
Plugin 'tpope/vim-fugitive'
Plugin 'vimoutliner/vimoutliner'
Plugin 'majutsushi/tagbar'
call vundle#end()            " required
filetype plugin indent on    " required

set encoding=utf-8
let g:languagetool_jar='$HOME/Downloads/LanguageTool-4.7/languagetool-commandline.jar'

" color scheme
set background=light
let g:solarized_termcolors=256
colorscheme solarized
syntax enable

" tab behaviour
set expandtab
set tabstop=4
"set shiftwidth=4

" UI
set number
set showcmd
set cursorline
filetype plugin indent on

set wildmenu
set lazyredraw
set showmatch
set guifont=Consolas:h12:cANSI:qDRAFT

" searching
set hlsearch
nnoremap <leader><space> :nohlsearch<CR>

" general behaviour
let mapleader=","
set backspace=2
set autoread
set foldmethod=syntax

let g:tex_flavor='latex'
let g:Tex_DefaultTargetFormat='pdf'
let g:Tex_MultipleCompileFormats='pdf'

I have the following files under C:\Users\Jordi\.vim\after\ftplugin with different indent settings and other settings

/Users/Jordi/.vim/
~ after/ftplugin/
    matlab.vim
    tex.vim
    arduino.vim
+ bundle/

The output of :filetype yields everything ON

When I check :scriptnames the ftplugin scripts are never being loaded.

What am I doing wrong? Thanks

Source Link

ftplugin not working in windows

This is my .vimrc

set nocompatible              " be iMproved, required
filetype off                  " required
" set the runtime path to include Vundle and initialize
set rtp+=~/.vim/bundle/Vundle.vim
call vundle#begin()
" alternatively, pass a path where Vundle should install plugins
"call vundle#begin('~/some/path/here')
" let Vundle manage Vundle, required
Plugin 'VundleVim/Vundle.vim'
Plugin 'altercation/vim-colors-solarized'
Plugin 'ycm-core/YouCompleteMe'
Plugin 'vim-latex/vim-latex'
Plugin 'vim-scripts/LanguageTool'
Plugin 'vim-airline/vim-airline'
Plugin 'scrooloose/nerdtree'
Plugin 'tpope/vim-fugitive'
Plugin 'vimoutliner/vimoutliner'
Plugin 'majutsushi/tagbar'
call vundle#end()            " required
filetype plugin indent on    " required

set encoding=utf-8
let g:languagetool_jar='$HOME/Downloads/LanguageTool-4.7/languagetool-commandline.jar'

" color scheme
set background=light
let g:solarized_termcolors=256
colorscheme solarized
syntax enable

" tab behaviour
set expandtab
set tabstop=4
"set shiftwidth=4

" UI
set number
set showcmd
set cursorline
filetype plugin indent on

set wildmenu
set lazyredraw
set showmatch
set guifont=Consolas:h12:cANSI:qDRAFT

" searching
set hlsearch
nnoremap <leader><space> :nohlsearch<CR>

" general behaviour
let mapleader=","
set backspace=2
set autoread
set foldmethod=syntax

let g:tex_flavor='latex'
let g:Tex_DefaultTargetFormat='pdf'
let g:Tex_MultipleCompileFormats='pdf'

I have the following files under C:\Users\Jordi\.vim\after\ftplugin with different indent settings and other settings

/Users/Jordi/.vim/
~ after/ftplugin/
    matlab.vim
    tex.vim
    arduino.vim
+ bundle/

The output of :filetype yields everything ON

When I check :scriptnames the ftplugin scripts are never being loaded.

What am I doing wrong? Thanks