4 edited body
source | link

I use YouCompleteMe for python3 code completion, and when I have

let g:ycm_python_binary_path = '/usr/bin/python3'

in my ~/.vimrc Itit works great. However, if I change it to

let python3path = system('/usr/bin/which python3')
let g:ycm_python_binary_path = python3path

It stops working. In both cases after vim startup the :echo g:ycm_python_binary_path shows /usr/bin/python3

What am I doing wrong?

I use YouCompleteMe for python3 code completion, and when I have

let g:ycm_python_binary_path = '/usr/bin/python3'

in my ~/.vimrc It works great. However, if I change it to

let python3path = system('/usr/bin/which python3')
let g:ycm_python_binary_path = python3path

It stops working. In both cases after vim startup the :echo g:ycm_python_binary_path shows /usr/bin/python3

What am I doing wrong?

I use YouCompleteMe for python3 code completion, and when I have

let g:ycm_python_binary_path = '/usr/bin/python3'

in my ~/.vimrc it works great. However, if I change it to

let python3path = system('/usr/bin/which python3')
let g:ycm_python_binary_path = python3path

It stops working. In both cases after vim startup the :echo g:ycm_python_binary_path shows /usr/bin/python3

What am I doing wrong?

3 added 3 characters in body
source | link

I use YouCompleteMe for python3 code ompletioncompletion, and when I have

let g:ycm_python_binary_path = '/usr/bin/python3'

in my ~/.vimrc~/.vimrc It works great. However, if I change it to

let python3path = system('/usr/bin/which python3')
let g:ycm_python_binary_path = python3path

It stops working. In both cases after vim startup the :echo g:ycm_python_binary_path shows /usr/bin/python3

What am I doing wrong?

I use YouCompleteMe for python3 code ompletion, and when I have

let g:ycm_python_binary_path = '/usr/bin/python3'

in my ~/.vimrc It works great. However, if I change it to

let python3path = system('/usr/bin/which python3')
let g:ycm_python_binary_path = python3path

It stops working. In both cases after vim startup the :echo g:ycm_python_binary_path shows /usr/bin/python3

What am I doing wrong?

I use YouCompleteMe for python3 code completion, and when I have

let g:ycm_python_binary_path = '/usr/bin/python3'

in my ~/.vimrc It works great. However, if I change it to

let python3path = system('/usr/bin/which python3')
let g:ycm_python_binary_path = python3path

It stops working. In both cases after vim startup the :echo g:ycm_python_binary_path shows /usr/bin/python3

What am I doing wrong?

2 edited tags; edited tags; edited tags
| link
1
source | link