Vi and Vim Stack Exchange is a question and answer site for people using the vi and Vim families of text editors. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using tpope's vim-markdown plugin to edit markdown files. Somehow, neovim hides the _ and * chars and changes the text in between to italic or bold depending on quantity of chars. I want to see these chars. How do I configure neovim or vim-markdown to not hide the chars? (note, I looked for vim-markdown help and there is none)

share|improve this question
    
Why don't you try the issue trackers? – mMontu Feb 16 at 15:55
    
In this case, I am not sure if it is neovim or vim-markdown question. – user1135541 Feb 16 at 16:03
    
you can use verbose set conceallevel to see which script change this option – wsdjeg Apr 26 at 15:37
up vote 11 down vote accepted

Those chars are hidden because the conceal feature as you can see on the vim-markdown source.

You can adjust how to this feature is applied to text using the option conceallevel. Setting it to 0 will always show the text.

:set conceallevel=0
share|improve this answer
    
OK, that works... – user1135541 Feb 16 at 16:28
    
I added the following line to my .vimrc file autocmd BufNewFile,BufRead *.md set conceallevel=0, but it does not apply, why? I wonder if some plugin changes it after the autocmd does, unless I am not setting it correctly. – user1135541 Apr 7 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.